Quo

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Contact Retrieval Issue
Resolved·Degraded performance

The issue has now been monitored to be resolved.

Thu, Feb 26, 2026, 05:00 PM
(3 months ago)
·
Affected components
Feb 26, 2026, 03:28 PM
04:39 PM
IOS App
Android App
Web App
Mac App
Windows App
Infrastructure
Quo API
Updates

Resolved

The issue has now been monitored to be resolved.

Thu, Feb 26, 2026, 05:00 PM

Monitoring

Systems are performing normally. We will continue to monitor and ensure that performance remains within acceptable levels.

Thu, Feb 26, 2026, 04:39 PM(21 minutes earlier)

Identified

We are currently experiencing a database performance issue which is impacting the retrieval and updating of contacts. The engineering team has identified the issue and are working to resolve the problem.

Thu, Feb 26, 2026, 03:28 PM(1 hour earlier)