Resolved
All systems are performing normally.
Monitoring
A fix for Tasks performance issues has been deployed and we are monitoring. Some actions may still be delayed and Task History may be affected while things settle. We will confirm once we have verified everything is back to normal.
Identified
We are aware with performance issues with Tasks and are investigating. Some actions may be delayed. Task History may be affected. We have identified the issue and are working on a fix.
Investigating
We are aware with performance issues with Tasks and are investigating. Some actions may be delayed. Task History may be affected.