Resolved
New Salesforce connections can now be made.
Identified
We are currently experiencing an issue establishing new account connections to Salesforce Data Cloud. Existing customer integrations are performing normally. Our engineering and partnership teams have identified the issue causing the failure and are working with the Salesforce support team to resolve the situation.