Monitoring
A fix has been deployed and call activity delays should be fully resolved shortly.
Investigating
We are investigating an issue causing delays to post-call activities, including missed call notifications, call recordings, and voicemails. This issue began at approximately 10:00 AM ET.
We are actively working to resolve this and will provide updates as we learn more.