Resolved
The root cause of the issue has been identified and a permanent fix has been prepared.
Identified
The engineering team have identified the system causing delivery errors and have implemented a remediation while we investigate root cause.
Investigating
We are investigating increased client error rates sending outbound MMS messages on the platform.