Monitoring
The engineering team has resolved the issue, all activities & notifications should be fully up to date at this time.
Investigating
We are currently experiencing a degradation in call activities. Some call activities will be missing or will be inaccurate during this time. The engineering team is investigating.