Quo

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Emergency Maintenance
Resolved·Full outage

Services have been successfully deployed. Call disruption was minimized. We again apologize for any adverse impact.

Sat, Apr 18, 2026, 01:21 AM
(2 months ago)
·
Affected components
Apr 18, 2026, 12:37 AM
01:21 AM
Calling
Voicemail
Text Messaging
IOS App
Android App
Web App
Mac App
Windows App
Updates

Resolved

Services have been successfully deployed. Call disruption was minimized. We again apologize for any adverse impact.

Sat, Apr 18, 2026, 01:21 AM

Investigating

We have experienced an urgent stability incident requiring an immediate deploy of system services. Unfortunately this deploy will cause a disruption of active calling sessions and interrupt inbound and outbound calling.

Our engineering team are working to execute this deployment in the least disruptive way possible.

We apologize for the impact.

Sat, Apr 18, 2026, 12:37 AM(43 minutes earlier)