Resolved
The incident with our mail service provider has been resolved. Service has been restored. We apologize for any inconvenience.
Identified
We are currently experiencing an outage caused by our email provider that may impact email communications with support. We are working with the vendor to address the issue as quickly as possible.