Resolved
The issue has now been monitored to be resolved.
Monitoring
Systems are performing normally. We will continue to monitor and ensure that performance remains within acceptable levels.
Identified
We are currently experiencing a database performance issue which is impacting the retrieval and updating of contacts. The engineering team has identified the issue and are working to resolve the problem.