Resolved
this issue was previously resolved.
Identified
The issue has been identified and resolved.
Investigating
We are currently investigating a service issue causing a small subset of organizations to experience slower than normal performance loading and searching contacts.