Office 365 users experiencing delayed OTP authentication emails
Resolved·Degraded performance

Delivery stats to Office365 hosted domains have returned to normal. All message delivery queues are healthy and within acceptable SLA.

Fri, Oct 3, 2025, 01:40 PM
(4 days ago)
·
Affected components
Web App
Updates

Resolved

Delivery stats to Office365 hosted domains have returned to normal. All message delivery queues are healthy and within acceptable SLA.

Fri, Oct 3, 2025, 01:40 PM

Monitoring

Message delivery to Office365 domains has returned to normal. We are continuing to monitor traffic to ensure delivery times remain within acceptable levels.

Thu, Oct 2, 2025, 09:34 PM(16 hours earlier)

Identified

We are aware of an issue causing delays in one-time password (OTP) delivery for Office 365 users. Affected users may use alternative login methods such as username & password or Google SSO as we continue to resolve this issue. Thank you for your patience.

Thu, Oct 2, 2025, 08:30 PM(1 hour earlier)