Calling Issues
Resolved·Full outage

Calling service has been fully restored.

Tue, Aug 26, 2025, 03:28 PM
(1 month ago)
·
Affected components
Calling
Updates

Resolved

Calling service has been fully restored.

Tue, Aug 26, 2025, 03:28 PM

Identified

The failed system has been restored. Service is recovering.

Tue, Aug 26, 2025, 03:19 PM

Identified

We have identified the issue impacting calling on the OpenPhone platform and the engineering team is working to remediate the issue. We expect service to be restored shortly.

Tue, Aug 26, 2025, 03:12 PM

Investigating

We're currently investigating some reports of calling issues. Our team is on it, and we'll share more information as soon as possible.

Tue, Aug 26, 2025, 02:45 PM(26 minutes earlier)