HubSpot + Jobber integrations
Resolved·Degraded performance

Our HubSpot and Jobber integrations should be working as expected for all users. Thank you for your patience while we resolved this.

Tue, Aug 19, 2025, 04:17 PM
(1 month ago)
·
Affected components
Integrations
Updates

Resolved

Our HubSpot and Jobber integrations should be working as expected for all users. Thank you for your patience while we resolved this.

Tue, Aug 19, 2025, 04:17 PM

Investigating

We’re aware of issues affecting our HubSpot and Jobber integrations for some customers. Our team is investigating and will share updates as soon as possible.

Tue, Aug 19, 2025, 03:31 PM(45 minutes earlier)